Fill function - not all cells get updated as the source cell is updated

#1

Hi,
in my app https://app.dashdash.com/editor/da11ca50-9a11-11e7-8503-4906168a1ce0/da11f160-9a11-11e7-8503-4906168a1ce0

Expected behaviour
I have used the fill function (see cell d10), to populate cells a3-b12 with the formula given in a2 and b2 (B1*$B$1). The function refers to $B$1, hence if I change B1 from 2 to 3 I would expect that B2=9; B3=27 and so on

Similar if I change B1 from 3 to 2 I would expect B2=4; B3=8 … B9=512 …

Actual result
When I change B1 from 3 to 2 the cells B1 to B8 are calculated as expected, however B9=3888 instead of the expected 512

Screenshot

Fill

#2

Hello @dknodt. Can you please tell me the content of cells b2 and d10?

I tried to reproduce, but I get B9 = 512, as expected.

Thanks:

#3

@humberto
B2=B1*$B$1
D10=FILL(A2:C2,10)

I am currently tethering with a mobile phone, perhaps the bad internet connection affects the values displayed.
The check in cells c1:c10 checks whether a1=b1 etc. and even though B9 shows a value that is unequal to A9, the C9 show True so perhaps there is problem with displaying the correct values (I use chrome on MacOS Sierra)

#4

@dknodt thanks for the quick reply.

It should not be your internet connection and it should not be your browser (or OS) either.

One last thing: can you provide me with what’s inside A2, A9 and B9?

Tks

#5

A2=A12
A9=A8
2
B9=B8*$B$1

thank you
asdfasdfasdfasdfasdfasdf (to get to 50 chars)

#6

Ok. Can you open B9 with and then again? Does it display 512 or still 3888?

#7

If I enter B9 and then click enter it calculates the value correctly as 512

#8

Ok. Its a problem with refreshing dependencies correctly.

You are correct that the value is assumed correctly when doing the logical comparison. But its displaying incorrectly in the view.

We will get on it.

Thanks!

#9

nice, thanks for the feedback. have a nice weekend and please get rid of the 60 char min :slight_smile:

#10

60 chars refers to the min chars for replies :slight_smile:

#11

already cut it to 40 for posts. (60 for first post)

1 Like
#12

@dknodt can you please test this behaviour in a new View and see if its still not working? It should be fixed now.

#13

@dknodt, I will go ahead and close this bug report. If there’s a problem, post here or create new report.

Thanks!